On Fri, Aug 1, 2008 at 8:01 PM, Jim Weirich <jim.weirich / gmail.com> wrote:
> On Aug 1, 2008, at 1:53 PM, Thomas Enebo wrote:
>>
>> I would assume a randomized array based on name.  Picking a good name is
>> tough.  Picking a better name is not so easy.  Array.give_me_something
>
>
> What about:
>
>     array.random_choice
> or   array.random_element

I agree with Tom, removing that rarely method would probably be the best.

As for names, take_random is better becasue we could also do
#take_random(10) -- to take 10 random elements :) This is similar to
what Array#take currently does: without argument it returns the first
element, otherwise it returns the specified nuber of elements.

Thanks,
  --Vladimir