On Jul 25, 2008, at 01:23 AM, Tanaka Akira wrote:
> In article <3454c9680807250045q6d3ecbe8n2692c899dc62a94a / mail.gmail.com 
> >,
>  "Vladimir Sizikov" <vsizikov / gmail.com> writes:
>
>> It could just be "mri'. For version numbers, you could then inspect
>
> RubyGems uses RUBY_ENGINE as a directory name:
>
> lib/rubygems/defaults.rb:
> [...]
>
> If RUBY_ENGINE is "mri", libdir/mri/gems/version is used as  
> default_dir.
>
> I guess RubyGems expects "ruby".

I expect the MRI value to be "ruby" as it is the reference  
implementation.