Jeremy,

On Jul 24, 2008, at 5:15 PM, Jeremy Henty wrote:
> Three of  the four  SortedSet  errors are  due to  RubySpec
> calling SortedSet#<=> ,  which does not exist in  either ruby_1_8_6 or
> ruby_1_8_7 .

 From what I can see we're not the ones calling #<=>, it's being  
called in #to_a to sort the set: 	

     (@keys = @hash.keys).sort! unless @keys

We're guarding it since as you said, no actions have been taken and we  
think that it's a plausible use case. I like the suggestion Arthur  
made on the ticket to undefine those methods for SortedSet if they're  
not going to be supported.

> I don't know what is causing the Iconv errors.  My Linux box is fairly
> aged, so it may be due to OS bugs (I've already had to disable some of
> the other tests for that  reason).  However, I've seen the same errors
> reported on this list, so it's not just me.

It is a platform specific behavior but I'm not sure if it's an "OS  
bug" or if it's reproducible on all Linux systems besides Debian/ 
Ubuntu. Maybe we can get someone to take a look and let us know what  
to do about it?

Having said that, I think these are minor issues that shouldn't stop  
the release of a new version, a lot of stuff has been fixed since the  
last official release.

--
Federico