On Fri, Jul 25, 2008 at 04:35:43AM +0900, Jeremy Henty wrote:
> On Fri, Jul 25, 2008 at 02:04:15AM +0900, Vladimir Sizikov wrote:
> 
> > The 1.8.6 and  1.8.7 branches have been OK  w.r.t. RubySpecs for a
> > while now,
> 
> I'm not  sure what you  mean by "OK",  but I'm still  getting errors
> with  the latest ruby_1_8_7  branch and  the latest  RubySpec.

To compare,  with the  latest ruby_1_8_6 branch  I get the  same Iconv
errors that I reported above,  but the SortedSet errors are gone.  The
relevant   SortedSet   tests    are   all   guarded   with   'ruby_bug
"http://redmine.ruby-lang.org/projects/ruby-18/issues/show?id=117",
"1.8.7.47"  do ...',  but if  you check  that URL  it appears  that no
action has been  taken.  In other words, RubySpec  seems to think that
this is some  bug that was fixed in 1.8.7.47 when  in fact nothing has
changed.   Three of  the four  SortedSet  errors are  due to  RubySpec
calling SortedSet#<=> ,  which does not exist in  either ruby_1_8_6 or
ruby_1_8_7 .

I don't know what is causing the Iconv errors.  My Linux box is fairly
aged, so it may be due to OS bugs (I've already had to disable some of
the other tests for that  reason).  However, I've seen the same errors
reported on this list, so it's not just me.

Regards, 

Jeremy Henty