Issue #340 has been reported by Ollivier Robert.

----------------------------------------
Bug #340: 1.9/trunk does not work when compiled with llvm-gcc4 2.3 (gcc 4.2.1)
http://redmine.ruby-lang.org/issues/show/340

Author: Ollivier Robert
Status: Open
Priority: Normal
Assigned to: 
Category: 
Target version: 


Ive tried llvm-gcc4 (http://www.llvm.org/) on both FreeBSD 7.0 & MacOS X 10.4 and both shows the same behaviour.  When configured with llvm-gcc as compiler, everything compiles fine but the first time miniruby is run (see below), it is spinning away, eating CPU circles and had to be killed with -9.

./miniruby -I../lib -I.ext/common -I./- -r../ext/purelib.rb  ../enc/make_encdb.rb ../enc encdb.h.new

Using built-in specs.
Target: x86_64-portbld-freebsd7.0
Configured with: ./../configure --enable-llvm=/usr/local --enable-languages=c,c++ --disable-nls --with-system-zlib --with-libiconv-prefix=/usr/local --program-prefix=llvm- --libdir=/usr/local/lib/llvm-gcc-2.3 --with-gxx-include-dir=/usr/local/lib/llvm-gcc-2.3/include/c++ --libexecdir=/usr/local/lib/llvm-gcc-2.3 --infodir=/usr/local/llvm-gcc --disable-shared --prefix=/usr/local --mandir=/usr/local/man --infodir=/usr/local/info/llvm-gcc x86_64-portbld-freebsd7.0
Thread model: posix
gcc version 4.2.1 (Based on Apple Inc. build 5555) (LLVM build)

BTW the configure script has a problem (I can open another ticket if you want) in that even if I specify CFLAGS="-O -pipe", the generated Makefile ends up with CFLAGS set to "-O -pipe -O2 -g"...


----------------------------------------
http://redmine.ruby-lang.org