I've been testing with 23.0.60, and I guess I used something new. I can 
reproduce the error in 22; I'll see if I can figure it out.

Nobuyoshi Nakada wrote:
> Hi,
>
> At Tue, 15 Jul 2008 09:30:21 +0900,
> Nathan Weizenbaum wrote in [ruby-core:17772]:
>   
>> One more patch which fixes a few bugs in the the last one.
>>     
>
> Now I tried your latest patch with Emacs 22.2.1, and it seems
> to get nothing fontified.  Which version of Emacs do you use?
>
>