In article <20080705122157.GA5572 / marlasina>,
  Gaston Ramos <ramos.gaston / gmail.com> writes:

> git --version
> git version 1.5.6

I found the thread about this problem.
[PATCH] clone: create intermediate directories of destination repo | KernelTrap
http://kerneltrap.org/mailarchive/git/2008/6/24/2209734

git 1.5.6 has the problem but 1.5.6.1 fixed it.

I changed update-rubyspec to avoid this problem.
-- 
Tanaka Akira