--=-eNVESuYWa29eJiiq4/Z9
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

Hi,

As Ed mentioned earlier today we now offer a version of ruby 1.8.6_p230
with the specific change the caused the Rails crashes reverted. I'm not
happy with this version but I'm seeing this as a stop-gap measure until
a properly fixed official 1.8.6 patchlevel release is done. Note that
this version already has one compilation bug reported on it, but I have
not yet had the time to investigate:
https://bugs.gentoo.org/show_bug.cgi?id=3D230111

As for ruby 1.8.7: althought we have ruby 1.8.7_p22 in our tree right
now, we don't offer it to our users (in Gentoo terms it is 'masked'). I
don't expect that this will change any time soon, given the
incompatibilities of between 1.8.6 and 1.8.7 and the fact that they
can't be sanely installed at the same time. If we were to release 1.8.7
we would break to much existing software that people depend on (if only
all the pre Rails-2.1.0 stuff).

Even with a properly announced deprecation timeline I would not expect
1.8.7 to be visible to our users in the next 6 months or so.

Kind regards,

Hans de Graaff
Gentoo Ruby project


--=-eNVESuYWa29eJiiq4/Z9
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEABECAAYFAkhobbMACgkQCzgcb6sPj48QBgCdFfK7YVfLdaQE2ZpSfJ5MS5tb
/mAAniL95x+7Oxcw/8VTCk+fhrE/Njpm
=89RT
-----END PGP SIGNATURE-----

--=-eNVESuYWa29eJiiq4/Z9--