Hi,

I've been following a blog[1] about the security patches, and 
updating ruby on my servers.

Updated to latest subversion ruby_1_8_6 branch, revision 17546.
(patchlevel 231)

However, still getting a seg fault on:

ruby -ve 'str = "A"*(2**16) ; loop{ str << str ; puts str.size }'
ruby 1.8.6 (2008-06-22 patchlevel 231) [i686-linux]
131072
262144
-e:1: [BUG] Segmentation fault


(If I should be posting this to a bug tracker rather than to
ruby-core, I'll be happy to, please let me know, thanks.)


[1] http://www.matasano.com/log/1070/updates-on-drew-yaos-terrible-ruby-vulnerabilities


Regards,

Bill