--pgp-sign-Multipart_Wed_Jun__4_03:28:44_2008-1
Content-Type: text/plain; charset=US-ASCII

Hi,

Earlier today I added a new instance method named `with_memo' to
Enumerable::Enumerator, but I'm not 100% sure if the name fits the
function.

Some other options I could think of include:

with:
    - too general; may clash with a reserved keyword in future

with_object:
    - not bad, but too unspecific and a bit too long to use often

with_obj:
    - looks terrible when we have ObjectSpace.each_object

with_accum:
    - too specific


Anyone think of a better name?

--
Akinori MUSHA / http://akinori.org/

--pgp-sign-Multipart_Wed_Jun__4_03:28:44_2008-1
Content-Type: application/pgp-signature
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (FreeBSD)

iEYEABECAAYFAkhFjVwACgkQkgvvx5/Z4e7X5wCgnhHmZ2MwlqAEL/ho9Ag7OIm4
VJkAn0z+kJqtj8H4Qvq48xHNl22zeyWc
=lLDZ
-----END PGP SIGNATURE-----

--pgp-sign-Multipart_Wed_Jun__4_03:28:44_2008-1--