In article <E1AKsY4-0008Cz-15 / odie.runbox.com>,
  "T. Onoma" <transami / runbox.com> writes:

> i don't see it being too much of a problem. why is it not so nice?

I don't like that.

* It is not called if content is empty.
* It may inform users that total may change.
* It cannot request progress without total, or total without progress.
  When an user know total by some applilcation specific way, total is useless.
  Although calculating total is no problem in HTTP, it require another
  network traffic in FTP.

> perhaps just convert nil to 0 instead and it will be a little better?

It unify "total size is unknown" and "total size is 0".
I think it should be distinguishable.
-- 
Tanaka Akira