On Sun, Mar 2, 2008 at 3:28 PM, Masoom <masoom.shaikh / gmail.com> wrote:
> Hello All,
>
> I feel it is well known that building ruby on windows does not build openssl
> and zlib (among few others). is it ? can anyone suggest how to build em ?
> configure script for windows provides no options either. I am not able to
> use gem.bat due to lack of zlib library. any thoughts ?
>

To build the zlib and openssl extensions you needa have the proper
include and libs into INCLUDE and LIB environment variables.
That means you need the source code or a "developer release" that
include the .h (include) and .lib (to bind/link with dll) of these
packages.

HTH,
-- 
Luis Lavena
Multimedia systems
-
A common mistake that people make when trying to design
something completely foolproof is to underestimate
the ingenuity of complete fools.
Douglas Adams