> Meanwhile try something like the following:

Thanks but...

> require 'rexml/document'
> foo = REXML::Document.new("<foo/>")
> bar = REXML::Formatters::Default.new

Now my Ruby 1.8.6-111 can't get around this:

   uninitialized constant REXML::Formatters

The source drop just contains:

   /usr/lib/lib/ruby/1.8/rexml$ ls formatter*
   default.rb  pretty.rb  transitive.rb

No formatters.rb to anchor them, so I can't just require 'rexml/formatters'. And 
  http://www.google.com/codesearch doesn't show any such thing waiting in the 
wings...

-- 
   Phlip