On Dec 27, 2007, at 06:45 AM, Richard Kilmer wrote:
> On Dec 27, 2007, at 12:30 AM, Dave Thomas wrote:
>> On Dec 26, 2007, at 10:50 PM, Eric Hodel wrote:
>>> I think it would be better to add a warning if  
>>> required_ruby_version is left at the default when building a gem.
>>
>> What about all the untouched gems on rubyforge, though. If folks  
>> don't update them for 1.9, thy gem won't get rebuilt and the  
>> warning won't get triggered. And these are exactly the gems I'm  
>> worried about.
>>
>> If instead we warn when the gem is used, we'll catch the untended  
>> gems. Hopefully, pressure from their users will then get the  
>> maintainers to update them
>
> I think it would be good to warn in 1.9 if the gem DOES NOT have the  
> required_ruby_version set (which most won't btw).

Here is a summary of the values of required_ruby_version for all the  
latest gems.  There are 2435 total.

[["> 0.0.0", 2077],
  [">= 0", 132],
  [">= 1.8.2", 52],
  [">= 1.8.0", 46],
  [">= 1.8.1", 35],
  [">= 1.8.4", 32],
  ["", 22],
  [">= 1.8.5", 14],
  [">= 1.8", 6],
  [">= 1.8.3", 5],
  [">= 1.8.6", 4],
  [">= 1.6", 2],
  [">= 1.6.8", 2],
  [">= 1.6.7", 2],
  ["> 1.8.0", 1],
  ["~> 1.8.4", 1],
  ["> 1.8.2", 1],
  [">= 1.9.0", 1]]

> Warn that this gem may not be compatible with Ruby 1.9.  It would  
> also be helpful to have this message at gem install time.  This is  
> an annoyance, and like Dave said, it will pressure people to update  
> them, but at least we will then know what gems are explicitly ready  
> for 1.9.


I have at least one gem that requires zero changes to operate on 1.9.

I don't want to spread FUD about my own gems when they work just fine,  
and I don't want to have to re-release my gems that work with a one- 
line change to say "no really".  I certainly don't want to force  
everybody else to do the same.

I understand the motives behind this request, but I think it is a poor  
change to make without knowing how many gems are actually broken on 1.9.

I should be able to say how many gems work on 1.8 but fail on 1.9 near  
the end of January.  I'm working on getting RubyGems working with  
Rubinius, then I'll overhaul my Tinderbox project.