Hi --

On Tue, 13 Nov 2007, Jordi wrote:

> We need "." for normal message sending
> and "send" or a more accurate name for not honoring visibility for
> compatibility.
>
>
> Anything else should be a synonym of one of the above.
>
>
> And yes, you are right, naming conventions are important. That's why
> "invoke_method" is awful as well as "send" when we are receiving. Not
> to mention that send should have ! (maybe not-honoring visibility send
> was an implementation error long time ago and not a feature)

I think it's extremely unlikely that send's ability to see private
methods was an error. It does, however, mean that having send and
send!, where send is the one that honors visibility, could cause
compabitility issues. I don't think that matters; I honestly don't
think very many people are going to be running 1.8 code under 1.9
without going over it very carefully and making necessary changes.


David

-- 
Upcoming training by David A. Black/Ruby Power and Light, LLC:
   * Advancing With Rails, Berlin, Germany, November 19-22
   * Intro to Rails, London, UK, December 3-6 (by Skills Matter)
See http://www.rubypal.com for details!