Hi,

In message "Re: method names in 1.9"
    on Sun, 11 Nov 2007 02:11:53 +0900, "David A. Black" <dblack / rubypal.com> writes:

|> - send, invoke_method

|I agree (no bang for safer version). I guess my favorite was send
|(safe) with send! (dangerous). I'm not sure what the best solution is
|if send is back to being the dangerous one.

I don't think it's a good idea to inverse it for bang's sake.  It
doesn't worth sacrifice compatibility.

|> - to_splat
|>
|> Unlike invoke_method above, you didn't provide your sought name.  It
|> must be a clear name to be use for splat.  Any opinion?
|> Regarding 'to_xxx', we have 'to_open' added in 1.9 that must be
|> irritate you.  It is used to implement open on anything other than
|> strings.
|
|I think "for_x" would be better than "to_x" for the ones where you're
|preparing the object for use by a specific operation. I'll learn to
|live with "splat" if I have to :-) But for_splat would be better than
|to_splat, I think.

"for_spat".  Hmm.  I don't prefer this over 'to_splat' but let me
think about it anyway.  I am still open for other input.

							matz.