Hi --

I know that a 1.9 feature-freeze is coming soon, but I just wanted to
put in a last-minute plea for some method name changes or removals.

"invoke_method" is one. I always take the trouble to explain to people
learning Ruby that sending a message and executing a method are not
same thing (even though they often happen together). "send" makes
sense: we're sending the object a message, explicitly. "invoke_method"
does not make sense. We're not invoking a method; we're sending a
message. The object then does something with the method.

"call_method" would be slightly better, though send/send! is still, I
think, the best mapping to the exclusion/inclusion of private methods.
It requires that people know about !-methods, and about private
methods, but they're supposed to anyway.

The other method name I strongly dislike is "to_splat". Aside from
"splat" being a kind of goofy, silly word, without any kind of
technical connotations, the whole "to_x" family always results in an
object of class X. "to_splat" represents a completely new semantics
for "to_x".

I know these (at least "to_splat") have been discussed here before,
and I really don't want to trigger a re-hash of those discussions
(which are findable in the archives).  Like I said, it's just a
last-minute plea. In particular, if I could be spared the thing about
how unimaginative I am because I don't want Ruby peppered with quirky,
whimsical, meaningless names, I'd count it a great kindness :-)

Thanks --


David

-- 
Upcoming training by David A. Black/Ruby Power and Light, LLC:
   * Advancing With Rails, Berlin, Germany, November 19-22
   * Intro to Rails, London, UK, December 3-6 (by Skills Matter)
See http://www.rubypal.com for details!