On 11/3/07, Urabe Shyouhei <shyouhei / ruby-lang.org> wrote:
> As a branch manager I think I cannot maintain YAML lib any longer. No
> one had touched lib/yaml for more than 20 months, while bugs are
> reported continuously during that. At this point I cannot but say YAML
> has already been abandoned. And I cannot maintain this large library by
> myself. It's a real sadness, but it's time for us to drop it from
> stdlib, unless someone put in for the maintenance.

Removal of YAML will break RubyGems, at least 0.9.4.

./rubygems/builder.rb
./rubygems/commands/build_command.rb
./rubygems/commands/specification_command.rb
./rubygems/config_file.rb
./rubygems/incremental_fetcher.rb
./rubygems/old_format.rb
./rubygems/package.rb
./rubygems/remote_fetcher.rb
./rubygems/remote_installer.rb
./rubygems/server.rb
./rubygems/source_index.rb
./rubygems/source_info_cache_entry.rb
./rubygems/specification.rb

More important that we find someone to maintain it if _why is
unwilling to do so.

-austin
-- 
Austin Ziegler * halostatue / gmail.com * http://www.halostatue.ca/
               * austin / halostatue.ca * http://www.halostatue.ca/feed/
               * austin / zieglers.ca