I haven't had a chance to narrow this down in enough detail yet, but 
there may be a memory leak in ruby-1.8.6-p110. Specifically, what I'm 
doing is

a. Gentoo Linux, amd64, gcc 4.2.1
b. Compiling ruby-1.8.6-p110 with "-g -pg" (profiling and debugging options)
c. Compiling the latest Ruby 1.9 from svn with full optimization 
(-march=athlon64, -O3)
d. Running the built-in benchmark suite of Ruby 1.9 with the Ruby from 
step b. as the "matz" Ruby and the Ruby 1.9 from step c. as the Ruby 1.9

When it gets to the "bm_loop_generate" benchmark, it hangs up in the 
1.8.6 run, and the Ruby interpreter grows arbitrarily large -- I killed 
it at 3 GB on my 4 GB machine.

I'm going to do some more digging before I file a bug report, but I'm 
wondering if anyone else has seen anything like this. I'm in the process 
of running the same scenario on a 32-bit system, so I haven't ruled in 
or out 64-bit, gcc, etc. at this point.