Hi All,

Just a suggestion - I know this business of naming methods can be
frustratingly difficult,
but I know that Mathematica names a very similar  function as
"RandomPermutation",
and a google search shows this name being used in other libraries as well.
Although it's a rather long name, wouldn't it be better to use an existing
standard,
rather than try to come up with something different ?

FWIW,

Tad

From Mathematica:
"RandomPermutation[n]
 generates a random permutation of the first  n natural numbers."

So in Ruby it could work as

a=["a","b","c"]
p randompermutation(a.size).collect {|i| a[i-1]}



                                                                           
           Internet                                                        
           warrenb@aquire                                                  
           .com                                                       Pour 
                                  ruby-core / ruby-lang.org                  
           17/09/2007                                                   cc 
           15:55                                                           
                                                                     Objet 
                                  Re: New array methods cycle, choice,     
              Veuillez            shuffle (plus bug in cycle)              
             rŮ—ondre                                                    
           ruby-core@ruby                                                  
             -lang.org                                                     
                                                                           
                                                                           
                                                                           




All,

    For the Array#choice method, how about a name of "deal"?  It would
make sense to anyone that has ever played cards to say myarray.deal(5).
It also would make sense to have an updating version myarray.deal!(5) to
remove the returned elements from the array.  It may not be the most
accurate description, but it certainly seems to describe the method
unambiguously.

    - Warren Brown


This message and any attachments (the "message") is intended solely for the addressees and is confidential. 
If you receive this message in error, please delete it and immediately notify the sender. Any use not in accord with 
its purpose, any dissemination or disclosure, either whole or partial, is prohibited except formal approval. 
The internet can not guarantee the integrity of this message. 
BNP PARIBAS (and its subsidiaries) shall (will) not therefore be liable for the message if modified. 
Do not print this message unless it is necessary, consider the environment.
                ---------------------------------------------
Ce message et toutes les pieces jointes (ci-apres le "message") sont etablis a l'intention exclusive de ses destinataires et sont confidentiels. Si vous recevez ce 
message par erreur, merci de le detruire et d'en avertir immediatement l'expediteur. 
Toute utilisation de ce message non conforme a sa destination, toute diffusion ou toute publication, totale ou partielle, est interdite, sauf autorisation expresse.
L'internet ne permettant pas d'assurer l'integrite de ce message, BNP PARIBAS (et ses filiales) decline(nt) toute responsabilite au titre de ce message, dans l'hypothese ou il aurait ete modifie.
N'imprimez ce message que si necessaire, pensez a l'environnement.