All,

    For the Array#choice method, how about a name of "deal"?  It would
make sense to anyone that has ever played cards to say myarray.deal(5).
It also would make sense to have an updating version myarray.deal!(5) to
remove the returned elements from the array.  It may not be the most
accurate description, but it certainly seems to describe the method
unambiguously.

    - Warren Brown