David Flanagan <david / davidflanagan.com> writes:

> choice returns a random element from the array.  I don't like the name
> of this method: neither the word "choice" nor it verb form "choose"
> imply randomness--instead they suggest the opposite.  I suggest just
> using the name "rand", "random" or "random_element". Most array
> methods are verbs, but a noun here would match the existing methods
> first and last.  Also, may I suggest a random! variant of the method
> that returns *and removes* a random element from the array?  first and
> last already have shift and pop to serve this purpose.

rand.rb uses #pick.

-- 
Christian Neukirchen  <chneukirchen / gmail.com>  http://chneukirchen.org