On 9/10/07, M. Edward (Ed) Borasky <znmeb / cesmail.net> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Urabe Shyouhei wrote:
> > Rocky Bernstein wrote:
> >
> >> I suggested it for 1.9 but there's no reason it couldn't go into 1.8 to
> >> gauge reception. (I've been using it a bit.)
> >
> > No there isn't.  It is quite possible that we include it for 1.8.7.
> > But not for 1.8.6. 1.8.6 has already been released and is now in
> > maintenance.  Bugs should be fixed but no new features should be
> > included for it.
> >
> >
>
> Given that 1.9 seems to be on track for a release towards the end of
> 2007, how much effort should be expended on Ruby 1.8.7? In fact, should
> there even *be* a Ruby 1.8.7? I think it would make users' lives harder,
> and I don't think the IronRuby, jRuby or Rubinius implementers need the
> distraction of new features on Ruby 1.8.x.

1.8.x will continue to need bugfix releases for quite some time after
the release of 1.9. There are many apps that will never need/want to
upgrade, just as there were with 1.6.

New features in 1.8.. I agree that those should only go in if they are
totally awesome. That decision will, of course, be up to the
maintainer in the end.