hi!

horray to the new JSON library. but why is it "JSON.generate" instead of
"JSON.dump", like in the YAML library? I think the two libraries should
share their interface. maybe the JSON method names are better.

[murphy]