Patches item #10283, was opened at 2007-04-21 14:46
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1700&aid=10283&group_id=426

>Category: Documentation, ri, and rdoc
Group: v1.8.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Pascal Terjan (pterjan)
Assigned to: Nobody (None)
Summary: rdoc --diagram does not support new graphviz

Initial Comment:
The test in check_diagram is

     if ver =~ /dot\s+version(?:\s+gviz)?\s+(\d+)\.(\d+)/
       ok = ($1.to_i > 1) || ($1.to_i == 1 && $2.to_i >= 8)
     end

But the version string that looked like "dot version 2.8 (Sun Aug 13 01:37:46 UTC 2006)" is now "dot - Graphviz version 2.12 (Wed Mar  7 21:41:22 UTC 2007)"

So, the first \s needs to be changed. Here is a patch, only tested on new graphviz

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1700&aid=10283&group_id=426