Bugs item #7430, was opened at 2006-12-23 21:56
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1698&aid=7430&group_id=426

>Category: Networking / Communication / P
Group: 1.9.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Francois GORET (fgoret)
Assigned to: Nobody (None)
Summary: cgi.rb still don't like 1.9

Initial Comment:
Hello,

Even after modifications by Matz (thanks !), cgi.rb sessions still resist working with 1.9.

The little attached cgi program works with 1.8.5, but dies with 1.9 revision 
11416 (svn):

/opt/ruby19/lib/ruby/1.9/cgi.rb:814:in `initialize': failed to splat (TypeError)
        from /opt/ruby19/lib/ruby/1.9/cgi/session.rb:284:in `Class#new'
        from /opt/ruby19/lib/ruby/1.9/cgi/session.rb:284:in `initialize'
        from /opt/ruby19/lib/ruby/1.9/cgi/session.rb:281:in `Kernel#instance_eval'
        from /opt/ruby19/lib/ruby/1.9/cgi/session.rb:281:in `initialize'
        from /opt/www/spider4/www/test2.cgi:7:in `Class#new'
        from /opt/www/spider4/www/test2.cgi:7

Francois

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1698&aid=7430&group_id=426