On 15/05/07, Nobuyoshi Nakada <nobu / ruby-lang.org> wrote:
> Hi,
>
> At Fri, 27 Apr 2007 02:30:31 +0900,
> Michal Suchanek wrote in [ruby-core:11039]:
> > As it turns out, ruby and miniruby only differ in the way
> > libruby-static is linked in. For miniruby it is linked directly by
> > full name, for ruby it is looked up with -l option.
> > So linking in another file would not fix the extensions for miniruby
> > nor prevent miniruby from loading potetntially broken and incompatible
> > extensions that are already installed. I think the object is present
> > in libruby anyway.
>
> Miniruby linked against dmydln.o is prevented from loading
> extensions at all.
yes, there is only dmyext.
>
> Anyway, isn't it solved by clearing default LOAD_PATH?
>
>
That patch does not apply to 1.8.6 anymore (at least not with the
linker flag patches already applied).
I will try to apply manually later.

Thanks

Michal