Bugs item #10140, was opened at 2007-04-16 17:32
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1698&aid=10140&group_id=426

Category: Core
Group: 1.8.6
Status: Open
Resolution: None
Priority: 3
Submitted By: Michal Suchanek (hramrach)
Assigned to: Nobody (None)
Summary: Cannot build with extra library path if previous version already installed

Initial Comment:
I tried building with LDFLAGS=-L/sw/lib which is the standard way to build a package with libraries outside of system library locations.

There is apparently already a libruby_static in there because the build has failed on an undefined symbol which was defined in ./libruby_static.a

I modified the Makefile so that it puts XLDFLAGS before LDFLAGS. That way I get -L. -L/sw/lib and the build works. However, if XLDFLAGS contained some linker options meant to override options in LDFLAGS it would not work this way.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1698&aid=10140&group_id=426