Issue #18192 has been updated by rhenium (Kazuki Yamaguchi).

Assignee set to rhenium (Kazuki Yamaguchi)

Adding OpenSSL 3.0 support is planned for the next Ruby/OpenSSL gem release, for inclusion in Ruby 3.1.

Given the amount of work required, doing so would be a sensible choice for Ruby 2.7 and 3.0 branches.

I will prepare new gem releases 2.1.x (for Ruby 2.7) and 2.2.x (for Ruby 3.0) and attach a patch here for ruby.git to import them.

----------------------------------------
Misc #18192: Advertise that OpenSSL 3.0 is not supported
https://bugs.ruby-lang.org/issues/18192#change-93839

* Author: xtkoba (Tee KOBAYASHI)
* Status: Open
* Priority: Normal
* Assignee: rhenium (Kazuki Yamaguchi)
----------------------------------------
Can we document that OpenSSL 3.0 is not supported?

I believe at least we can make `extconf.rb` fail with OpenSSL 3.0:

```diff
--- a/ext/openssl/extconf.rb
+++ b/ext/openssl/extconf.rb
@@ -108,10 +108,12 @@
     try_static_assert("LIBRESSL_VERSION_NUMBER >= 0x30100000L", "openssl/opensslv.h") }
 else
   checking_for("OpenSSL version >= 1.0.2") {
-    try_static_assert("OPENSSL_VERSION_NUMBER >= 0x10002000L", "openssl/opensslv.h") }
+    try_static_assert("OPENSSL_VERSION_NUMBER >= 0x10002000L", "openssl/opensslv.h") } &&
+  checking_for("OpenSSL version < 3.0.0") {
+    try_static_assert("OPENSSL_VERSION_NUMBER < 0x30000000L", "openssl/opensslv.h") }
 end
 unless version_ok
-  raise "OpenSSL >= 1.0.2 or LibreSSL >= 3.1.0 is required"
+  raise "OpenSSL >= 1.0.2, < 3.0.0 or LibreSSL >= 3.1.0 is required"
 end
 
 # Prevent wincrypt.h from being included, which defines conflicting macro with openssl/x509.h
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>