Issue #18022 has been updated by Eregon (Benoit Daloze).


What you wrote above is almost correct, but it should be `ruby_version_is "=
2.6.3"..."3.1" do`.
It's an exclusive range, and so until 3.1.

From a `ruby_version_is` point of view, the `dev` part of `3.1.0dev` is irr=
elevant, because it only checks RUBY_VERSION, and that's `"3.1.0"`.

----------------------------------------
Bug #18022: Spec errors for rbconfig/unicode_[emoji_]version_spec: Using Ru=
by 2.7 even when on Ruby 3.1
https://bugs.ruby-lang.org/issues/18022#change-92766

* Author: duerst (Martin D=FCrst)
* Status: Feedback
* Priority: Normal
* Assignee: Eregon (Benoit Daloze)
* ruby -v: ruby 3.1.0dev (2021-07-04T08:11:22Z master 0a931ef8f9) [x86_64-l=
inux]
* Backport: 2.6: UNKNOWN, 2.7: UNKNOWN, 3.0: UNKNOWN
----------------------------------------




-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>