Issue #18022 has been updated by Eregon (Benoit Daloze).


I see, you simply need to adapt the guards, like:

```ruby
  ruby_version_is "2.6.3"..."3.1.0" do
    it "is 12.1.0 for Ruby 2.6.3+ to Ruby 3.1.0" do
      RbConfig::CONFIG['UNICODE_VERSION'].should =3D=3D "12.1.0"
    end
  end

  ruby_version_is "3.1.0" do
    it "is 13.0.0 for Ruby 2.3.1+" do
      RbConfig::CONFIG['UNICODE_VERSION'].should =3D=3D "13.0.0"
    end
  end
```

Older dev versions are basically considered non-existing in specs/tests, so=
 we can just ignore that.

----------------------------------------
Bug #18022: Spec errors for rbconfig/unicode_[emoji_]version_spec: Using Ru=
by 2.7 even when on Ruby 3.1
https://bugs.ruby-lang.org/issues/18022#change-92765

* Author: duerst (Martin D=FCrst)
* Status: Feedback
* Priority: Normal
* Assignee: Eregon (Benoit Daloze)
* ruby -v: ruby 3.1.0dev (2021-07-04T08:11:22Z master 0a931ef8f9) [x86_64-l=
inux]
* Backport: 2.6: UNKNOWN, 2.7: UNKNOWN, 3.0: UNKNOWN
----------------------------------------




-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>