Issue #17770 has been updated by jeremyevans0 (Jeremy Evans).

Status changed from Open to Third Party's Issue

This does appear to be a sassc bug: https://github.com/sass/sassc-ruby/issues/207

----------------------------------------
Bug #17770: Assets precompilation aborts with Segmentation fault
https://bugs.ruby-lang.org/issues/17770#change-91266

* Author: dvodvodvo (Jerome Camus)
* Status: Third Party's Issue
* Priority: Normal
* ruby -v: ruby 2.6.1p33 (2019-01-30 revision 66950) [x86_64-linux]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN, 3.0: UNKNOWN
----------------------------------------
ruby 2.6.1p33 (2019-01-30 revision 66950) [x86_64-linux]

What changed?  I updated a gem version, administrate 0.14.0 to 0.15.0

   when deploying to server the following error is constantly appearing. 
Note: when reverting to version 0.14.0 the deployment process completes  (I will also be reporting this to the administrate gem)
 
The same occurs if I log into the server, find the current release and run `bundle exec rake assets:precompile`

Log (capistrano) attached


---Files--------------------------------
capistrano_log_administrate.txt (318 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>