Issue #17057 has been updated by jeremyevans0 (Jeremy Evans).

Status changed from Open to Closed

I've merged the patch in the pull request after adding a test for it: https=
://github.com/ruby/cgi/pull/4

----------------------------------------
Bug #17057: CGI different behaviour with C vs Ruby version
https://bugs.ruby-lang.org/issues/17057#change-90588

* Author: ahorek (Pavel Rosick=FD)
* Status: Closed
* Priority: Normal
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
```
irb(main):001:0> require 'cgi' # don't load a native extension
irb(main):002:0> CGI.unescapeHTML("\xFF&")
=3D> ArgumentError (invalid byte sequence in UTF-8)
```

there's a fix on upstream https://github.com/ruby/cgi/pull/2



-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>