Issue #17582 has been updated by hsbt (Hiroshi SHIBATA).

Backport changed from 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN, 3.0: UNKNOWN to 2.5: UNKNOWN, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: REQUIRED

Thanks nobu. I confirmed to build with bison-3.7.5

----------------------------------------
Bug #17582: Build failure with bison-3.7.5
https://bugs.ruby-lang.org/issues/17582#change-90114

* Author: hsbt (Hiroshi SHIBATA)
* Status: Closed
* Priority: Normal
* Backport: 2.5: UNKNOWN, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: REQUIRED
----------------------------------------
I got the following error with bison 3.7.5 provided by homebrew on macOS Catalina.

```
parse.y:13337:5: error: implicit declaration of function 'YYUSE' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
    YYUSE(p);
    ^
1 error generated.
make: *** [parse.o] Error 1
make: *** Waiting for unfinished jobs....
```

I could build with bison-2.3 provided by system toolchain by macOS.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>