On 2/6/07, dblack / wobblini.net <dblack / wobblini.net> wrote:
> Hi --
>
> On Tue, 6 Feb 2007, Nikolai Weibull wrote:
>
> > On 2/6/07, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
> >
> >> Both having ordAt(index) or making String#ord to return codepoint of
> >> the first character are trivial.  We have to evaluate pros and cons
> >> first.
> >
> > Like the fact that #ordAt isn't a very Rubyish name.  I really
> > appreciate the fact that the core and standard libraries use very
> > consistent naming schemes, where most methods have only one word in
> > them, thus avoiding the whole
> > came-case-versus-internal-upcasing-versus-lowline-separating-naming-scheme
> > holy-war.
>
> There are quite a few multi-word methods (respond_to?, values_at,
> to_i, instance_methods, etc.), all with the underscore style.  I agree
> there's no "war" aspect to it, but there's definitely a traditional
> style.

What I meant was that it seems that people have been clever enough to
avoid multi-word methods as far as possible, so that there really
never has to be a discussion about it.  I know that the naming
conventions are camel-case for constants and lowlines for everything
else, but I realized early while reading through the early
documentation that every method seemed to have a very good single-word
name.

This was a side track for sure, but I wanted to mention it nonetheless.

  nikolai