Hi --

On Tue, 6 Feb 2007, Nikolai Weibull wrote:

> On 2/6/07, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
>
>> Both having ordAt(index) or making String#ord to return codepoint of
>> the first character are trivial.  We have to evaluate pros and cons
>> first.
>
> Like the fact that #ordAt isn't a very Rubyish name.  I really
> appreciate the fact that the core and standard libraries use very
> consistent naming schemes, where most methods have only one word in
> them, thus avoiding the whole
> came-case-versus-internal-upcasing-versus-lowline-separating-naming-scheme
> holy-war.

There are quite a few multi-word methods (respond_to?, values_at,
to_i, instance_methods, etc.), all with the underscore style.  I agree
there's no "war" aspect to it, but there's definitely a traditional
style.


David

-- 
Q. What is THE Ruby book for Rails developers?
A. RUBY FOR RAILS by David A. Black (http://www.manning.com/black)
    (See what readers are saying!  http://www.rubypal.com/r4rrevs.pdf)
Q. Where can I get Ruby/Rails on-site training, consulting, coaching?
A. Ruby Power and Light, LLC (http://www.rubypal.com)