Issue #17491 has been updated by mame (Yusuke Endoh).

Status changed from Open to Feedback

Currently, Ruby does not support Android officially. A patch is welcome.

I'm experimentally maintaining a CI on Android/Termux (http://rubyci.s3.amazonaws.com/android29-x86_64/ruby-master/recent.html), and it is only a test environment for Ruby with Android. Currently, no CI for cross-compilation is maintained unfortunately.

----------------------------------------
Bug #17491: `./configure' unsuccessful on Android NDK cross-build
https://bugs.ruby-lang.org/issues/17491#change-89664

* Author: xtkoba (Tee KOBAYASHI)
* Status: Feedback
* Priority: Normal
* ruby -v: ruby 3.0.0p0 (2020-12-25 revision 95aff21468) [x86_64-linux]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
We have no such command as `getprop` in our Android NDK cross-build environment, and so `./configure` says
```
checking whether it is Android... yes
checking for Android API version... ./configure: line 9108: getprop: command not found
```
and finally dies saying
```
configure: error: size_t is signed
```




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>