Hi,

In message "Re: [ ruby-Patches-8309 ] add usage of uri.userinfo to open-uri.rb"
    on Wed, 31 Jan 2007 22:34:47 +0900, Paulo K?ch <paulo.koch / gmail.com> writes:

|> According to RFC3986, supporting userinfo in URI is dangerous, so that
|> open-uri will not support it.
|
|Shouldn't that be, at least, a warning or something?

open-uri raises error for URI with userinfo when you use Ruby 1.9 or
later.

							matz.