Issue #17328 has been updated by jeremyevans0 (Jeremy Evans).


This has the potential to introduce security issues.  Avoiding security issues by not automatically loading files in the current directory is the reason `.` was removed from the default `$LOAD_PATH` in Ruby 1.9.

----------------------------------------
Feature #17328: Extend `un.rb` to be usable by everyone
https://bugs.ruby-lang.org/issues/17328#change-88525

* Author: sdwolfz (Codru Guoi)
* Status: Open
* Priority: Normal
----------------------------------------
I've opened the PR here: https://github.com/ruby/ruby/pull/3771, although if you need me to submit a patch just let me know.
Basically I want to be able to use `ruby -run` for more than just running a http server, and thought it could require a local `run.rb` file with code that end users provide.

Not sure if this was proposed before but let me know what you think.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>