> IOArray Point Color ->  IO (IOArray Point Color) なら具体的なインスタンス
> として通るようですね。

IOArray Point Color -> IOArray Point Color という意図で考えていた
プログラムを、型システムを黙らせるためだけに、型宣言だけを、
IOArray Point Color -> IO (IOArray Point Color) に換えて、
大丈夫なんですか?それで、プログラムが意図したとおり動くのですか?

--nobsun

--
ML: haskell-jp / quickml.com
使い方: http://QuickML.com/